re = /(^\d{4}(-\d{2}){2}([^|]+\|){3})([\s\S]*?)\n*(?=^\d{4}.*?(?:[^|\n]+\|){3}|\z)/m
str = '2015-03-03 19:30:47.2725|INFO|MyApp|This is a single line log message.
2015-03-03 19:31:29.1209|INFO|MyApp|This log message has multiple
lines with
2015-03-03
a date in it.
2015-03-03 19:32:50.1106|INFO|MyApp|This log message has
multiple lines
but just text only.
2015-03-03 19:33:20.2683|ERROR|MyApp|This log message has multiple lines but
also some confusing text like
2015-03-03 19:33:20.2683|ERROR| which should
still be a valid log message.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end