import re
regex = re.compile(r"(^\d{4}(-\d{2}){2}([^|]+\|){3})([\s\S]*?)\n*(?=^\d{4}.*?(?:[^|\n]+\|){3}|\z)", flags=re.MULTILINE)
test_str = ("2015-03-03 19:30:47.2725|INFO|MyApp|This is a single line log message.\n\n"
"2015-03-03 19:31:29.1209|INFO|MyApp|This log message has multiple\n"
"lines with\n"
"2015-03-03\n"
"a date in it.\n\n"
"2015-03-03 19:32:50.1106|INFO|MyApp|This log message has\n"
"multiple lines\n"
"but just text only.\n\n"
"2015-03-03 19:33:20.2683|ERROR|MyApp|This log message has multiple lines but\n"
"also some confusing text like\n"
"2015-03-03 19:33:20.2683|ERROR| which should\n"
"still be a valid log message.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")