using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<number>
(?:
\d+
(?:\.\d*)?
)|
(?:\d*\.\d+)
)|
(?<immediate>
(?<str>
(?:
'
(?<__str__>
(?:[^'\\]|\\')*
)
'
)|
(?:
\
(?<__str__>.)
)
)|
(?<operator>
(?:
p|
\»|
R|
\_|
\-|
\°|
r|
\∩|
\«|
\∞|
\∅|
\~|
\/|
\]|
C|
\%|
P|
\*|
\^|
\∪|
d|
\[|
F|
l|
s|
\!|
\+|
\=|
h|
f|
c
)
)|
(?<apply>\$)|
(?<space>\s+)
)";
string input = @"a '234'";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace | RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}