$re = '/(?<number>
(?:
\d+
(?:\.\d*)?
)|
(?:\d*\.\d+)
)|
(?<immediate>
(?<str>
(?:
\'
(?<__str__>
(?:[^\'\\\\]|\\\\\')*
)
\'
)|
(?:
\
(?<__str__>.)
)
)|
(?<operator>
(?:
p|
\»|
R|
\_|
\-|
\°|
r|
\∩|
\«|
\∞|
\∅|
\~|
\/|
\]|
C|
\%|
P|
\*|
\^|
\∪|
d|
\[|
F|
l|
s|
\!|
\+|
\=|
h|
f|
c
)
)|
(?<apply>\$)|
(?<space>\s+)
)/mxuJ';
$str = 'a \'234\'';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);