re = /(?<number>
(?:
\d+
(?:\.\d*)?
)|
(?:\d*\.\d+)
)|
(?<immediate>
(?<str>
(?:
'
(?<__str__>
(?:[^'\\]|\\')*
)
'
)|
(?:
\
(?<__str__>.)
)
)|
(?<operator>
(?:
p|
\»|
R|
\_|
\-|
\°|
r|
\∩|
\«|
\∞|
\∅|
\~|
\/|
\]|
C|
\%|
P|
\*|
\^|
\∪|
d|
\[|
F|
l|
s|
\!|
\+|
\=|
h|
f|
c
)
)|
(?<apply>\$)|
(?<space>\s+)
)/mx
str = 'a \'234\''
# Print the match result
str.match(re) do |match|
puts match.to_s
end