const regex = /(?<number>
(?:
\d+
(?:\.\d*)?
)|
(?:\d*\.\d+)
)|
(?<immediate>
(?<str>
(?:
'
(?<__str__>
(?:[^'\\]|\\')*
)
'
)|
(?:
\
(?<__str__>.)
)
)|
(?<operator>
(?:
p|
\»|
R|
\_|
\-|
\°|
r|
\∩|
\«|
\∞|
\∅|
\~|
\/|
\]|
C|
\%|
P|
\*|
\^|
\∪|
d|
\[|
F|
l|
s|
\!|
\+|
\=|
h|
f|
c
)
)|
(?<apply>\$)|
(?<space>\s+)
)/mu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<number>
(?:
\\d+
(?:\\.\\d*)?
)|
(?:\\d*\\.\\d+)
)|
(?<immediate>
(?<str>
(?:
\'
(?<__str__>
(?:[^\'\\\\]|\\\\\')*
)
\'
)|
(?:
\\
(?<__str__>.)
)
)|
(?<operator>
(?:
p|
\\»|
R|
\\_|
\\-|
\\°|
r|
\\∩|
\\«|
\\∞|
\\∅|
\\~|
\\\/|
\\]|
C|
\\%|
P|
\\*|
\\^|
\\∪|
d|
\\[|
F|
l|
s|
\\!|
\\+|
\\=|
h|
f|
c
)
)|
(?<apply>\\$)|
(?<space>\\s+)
)', 'mu')
const str = `a '234'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}