using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\bAPPLE.*\bPIE[\s\d]*[^-]*$";
string input = @"SWEET APPLE 1 - PIE 2
SWEET APPLE 1 - PIE 2 IS GOOD
SWEET APPLE 1 - PIE3
SWEET APPLE 1 - PIE 1-3 IS GOOD";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}