$re = '/^.*\bAPPLE.*\bPIE[\s\d]*[^-]*$/m';
$str = 'SWEET APPLE 1 - PIE 2
SWEET APPLE 1 - PIE 2 IS GOOD
SWEET APPLE 1 - PIE3
SWEET APPLE 1 - PIE 1-3 IS GOOD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);