package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\bAPPLE.*\bPIE[\s\d]*[^-]*$`)
var str = `SWEET APPLE 1 - PIE 2
SWEET APPLE 1 - PIE 2 IS GOOD
SWEET APPLE 1 - PIE3
SWEET APPLE 1 - PIE 1-3 IS GOOD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}