using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":(key\d)+\[([^\]]+)\]";
string input = @":key1[value]:key2[this:value should work too]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}