re = /:(key\d)+\[([^\]]+)\]/
str = ':key1[value]:key2[this:value should work too]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end