$re = '/:(key\d)+\[([^\]]+)\]/';
$str = ':key1[value]:key2[this:value should work too]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);