package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`:(key\d)+\[([^\]]+)\]`)
var str = `:key1[value]:key2[this:value should work too]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}