#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)# Define the opening and closing elements before the recursion occurs" & @CRLF & _
"(?(DEFINE)" & @CRLF & _
" (?<open_curly>\{)" & @CRLF & _
" (?<close_curly>\})" & @CRLF & _
" (?<open_square>\[)" & @CRLF & _
" (?<close_square>\])" & @CRLF & _
" (?P<open_pascal>(?i:\bbegin\b))" & @CRLF & _
" (?P<close_pascal>(?i:\bend\b))" & @CRLF & _
" (?P<open_lua>--\[)" & @CRLF & _
" (?P<close_lua>--\])" & @CRLF & _
" (?<open>\g'open_curly'|\g'open_square'|\g'open_pascal'|\g'open_lua')" & @CRLF & _
" (?<close>\g'close_curly'|\g'close_square'|\g'close_pascal'|\g'close_lua')" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"# Match the opening element" & @CRLF & _
"(\g'open'" & @CRLF & _
" (?>" & @CRLF & _
" # For recursion, don't match either the opening" & @CRLF & _
" # or closing element" & @CRLF & _
" (?!\g'open'|\g'close')(.)" & @CRLF & _
" |" & @CRLF & _
" # Recurse this captured pattern" & @CRLF & _
" (?-1)" & @CRLF & _
" )*" & @CRLF & _
"" & @CRLF & _
"# Match the closing element" & @CRLF & _
"\g'close')" & @CRLF & _
""
Local $sString = "EVENLY BALANCED curly braces" & @CRLF & _
"" & @CRLF & _
"{{{}}}" & @CRLF & _
"{ test1 { test2 { test3 { test4 } } } }" & @CRLF & _
"" & @CRLF & _
"UNEVENLY BALANCED curly braces" & @CRLF & _
"{{{{}}}" & @CRLF & _
"{ test1 { test2 { test3 { test4 } } } } }" & @CRLF & _
"" & @CRLF & _
"MULTI-LINE EVENLY BALANCED curly braces" & @CRLF & _
"{" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"MULTI-LINE UNEVENLY BALANCED curly braces" & @CRLF & _
"{{" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"EVENLY BALANCED square braces" & @CRLF & _
"[ test1 [ test2 [ test3 [ test4 ] ] ] ]" & @CRLF & _
"" & @CRLF & _
"EVENLY BALANCED square and curly braces" & @CRLF & _
"{ test1 [ test2 { test3 [ test4 ] } ] }" & @CRLF & _
"" & @CRLF & _
"UNEVENLY BALANCED square and curly braces" & @CRLF & _
"{ test1 [ test2 { test3 [ test4 ] } } ]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")