const regex = /# Define the opening and closing elements before the recursion occurs
(?(DEFINE)
(?<open_curly>\{)
(?<close_curly>\})
(?<open_square>\[)
(?<close_square>\])
(?P<open_pascal>(?i:\bbegin\b))
(?P<close_pascal>(?i:\bend\b))
(?P<open_lua>--\[)
(?P<close_lua>--\])
(?<open>\g'open_curly'|\g'open_square'|\g'open_pascal'|\g'open_lua')
(?<close>\g'close_curly'|\g'close_square'|\g'close_pascal'|\g'close_lua')
)
# Match the opening element
(\g'open'
(?>
# For recursion, don't match either the opening
# or closing element
(?!\g'open'|\g'close')(.)
|
# Recurse this captured pattern
(?-1)
)*
# Match the closing element
\g'close')
/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('# Define the opening and closing elements before the recursion occurs
(?(DEFINE)
(?<open_curly>\\{)
(?<close_curly>\\})
(?<open_square>\\[)
(?<close_square>\\])
(?P<open_pascal>(?i:\\bbegin\\b))
(?P<close_pascal>(?i:\\bend\\b))
(?P<open_lua>--\\[)
(?P<close_lua>--\\])
(?<open>\\g\'open_curly\'|\\g\'open_square\'|\\g\'open_pascal\'|\\g\'open_lua\')
(?<close>\\g\'close_curly\'|\\g\'close_square\'|\\g\'close_pascal\'|\\g\'close_lua\')
)
# Match the opening element
(\\g\'open\'
(?>
# For recursion, don\'t match either the opening
# or closing element
(?!\\g\'open\'|\\g\'close\')(.)
|
# Recurse this captured pattern
(?-1)
)*
# Match the closing element
\\g\'close\')
', 'g')
const str = `EVENLY BALANCED curly braces
{{{}}}
{ test1 { test2 { test3 { test4 } } } }
UNEVENLY BALANCED curly braces
{{{{}}}
{ test1 { test2 { test3 { test4 } } } } }
MULTI-LINE EVENLY BALANCED curly braces
{
}
MULTI-LINE UNEVENLY BALANCED curly braces
{{
}
EVENLY BALANCED square braces
[ test1 [ test2 [ test3 [ test4 ] ] ] ]
EVENLY BALANCED square and curly braces
{ test1 [ test2 { test3 [ test4 ] } ] }
UNEVENLY BALANCED square and curly braces
{ test1 [ test2 { test3 [ test4 ] } } ]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}