import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# Define the opening and closing elements before the recursion occurs\n"
+ "(?(DEFINE)\n"
+ " (?<open_curly>\\{)\n"
+ " (?<close_curly>\\})\n"
+ " (?<open_square>\\[)\n"
+ " (?<close_square>\\])\n"
+ " (?P<open_pascal>(?i:\\bbegin\\b))\n"
+ " (?P<close_pascal>(?i:\\bend\\b))\n"
+ " (?P<open_lua>--\\[)\n"
+ " (?P<close_lua>--\\])\n"
+ " (?<open>\\g'open_curly'|\\g'open_square'|\\g'open_pascal'|\\g'open_lua')\n"
+ " (?<close>\\g'close_curly'|\\g'close_square'|\\g'close_pascal'|\\g'close_lua')\n"
+ ")\n\n"
+ "# Match the opening element\n"
+ "(\\g'open'\n"
+ " (?>\n"
+ " # For recursion, don't match either the opening\n"
+ " # or closing element\n"
+ " (?!\\g'open'|\\g'close')(.)\n"
+ " |\n"
+ " # Recurse this captured pattern\n"
+ " (?-1)\n"
+ " )*\n\n"
+ "# Match the closing element\n"
+ "\\g'close')\n";
final String string = "EVENLY BALANCED curly braces\n\n"
+ "{{{}}}\n"
+ "{ test1 { test2 { test3 { test4 } } } }\n\n"
+ "UNEVENLY BALANCED curly braces\n"
+ "{{{{}}}\n"
+ "{ test1 { test2 { test3 { test4 } } } } }\n\n"
+ "MULTI-LINE EVENLY BALANCED curly braces\n"
+ "{\n"
+ "}\n\n"
+ "MULTI-LINE UNEVENLY BALANCED curly braces\n"
+ "{{\n"
+ "}\n\n\n"
+ "EVENLY BALANCED square braces\n"
+ "[ test1 [ test2 [ test3 [ test4 ] ] ] ]\n\n"
+ "EVENLY BALANCED square and curly braces\n"
+ "{ test1 [ test2 { test3 [ test4 ] } ] }\n\n"
+ "UNEVENLY BALANCED square and curly braces\n"
+ "{ test1 [ test2 { test3 [ test4 ] } } ]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}