const regex = /(?:\b|\.|\s)+(d{1,4}|m{1,4}|y{4}|y{2}){1}(?:\.|\s){1}(d{1,4}|m{1,4}|y{4}|y{2})?(?:\.|\s)?(d{1,4}|m{1,4}|y{4}|y{2})?(?:\.|\s)?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b|\\.|\\s)+(d{1,4}|m{1,4}|y{4}|y{2}){1}(?:\\.|\\s){1}(d{1,4}|m{1,4}|y{4}|y{2})?(?:\\.|\\s)?(d{1,4}|m{1,4}|y{4}|y{2})?(?:\\.|\\s)?', 'gmi')
const str = `"DD.MM": DD.MM
"DD.MM.YY": DD.MM.YY
"Форматы внутри строки в кавычках DD.MM.YYYY не учитывать": DD.MM.YYYY "и тут dd.mm тоже"
"Поход: " DD.MM. ", кино:" DD.mm
"Datum kann in der Mitte sein" DD.MM.YYYY "oder sogar an Ende" DD.MM.YY
Форматы без разделителя DDMMYYYY не учитывать
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}