import Foundation
let pattern = #"(?:\b|\.|\s)+(d{1,4}|m{1,4}|y{4}|y{2}){1}(?:\.|\s){1}(d{1,4}|m{1,4}|y{4}|y{2})?(?:\.|\s)?(d{1,4}|m{1,4}|y{4}|y{2})?(?:\.|\s)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
"DD.MM": DD.MM
"DD.MM.YY": DD.MM.YY
"Форматы внутри строки в кавычках DD.MM.YYYY не учитывать": DD.MM.YYYY "и тут dd.mm тоже"
"Поход: " DD.MM. ", кино:" DD.mm
"Datum kann in der Mitte sein" DD.MM.YYYY "oder sogar an Ende" DD.MM.YY
Форматы без разделителя DDMMYYYY не учитывать
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)