import re
regex = re.compile(r"(?:\b|\.|\s)+(d{1,4}|m{1,4}|y{4}|y{2}){1}(?:\.|\s){1}(d{1,4}|m{1,4}|y{4}|y{2})?(?:\.|\s)?(d{1,4}|m{1,4}|y{4}|y{2})?(?:\.|\s)?", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("\"DD.MM\": DD.MM\n"
"\"DD.MM.YY\": DD.MM.YY\n"
"\"Форматы внутри строки в кавычках DD.MM.YYYY не учитывать\": DD.MM.YYYY \"и тут dd.mm тоже\"\n"
"\"Поход: \" DD.MM. \", кино:\" DD.mm\n"
"\"Datum kann in der Mitte sein\" DD.MM.YYYY \"oder sogar an Ende\" DD.MM.YY\n"
"Форматы без разделителя DDMMYYYY не учитывать\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")