$re = '/(?:\b|\.|\s)+(d{1,4}|m{1,4}|y{4}|y{2}){1}(?:\.|\s){1}(d{1,4}|m{1,4}|y{4}|y{2})?(?:\.|\s)?(d{1,4}|m{1,4}|y{4}|y{2})?(?:\.|\s)?/mi';
$str = '"DD.MM": DD.MM
"DD.MM.YY": DD.MM.YY
"Форматы внутри строки в кавычках DD.MM.YYYY не учитывать": DD.MM.YYYY "и тут dd.mm тоже"
"Поход: " DD.MM. ", кино:" DD.mm
"Datum kann in der Mitte sein" DD.MM.YYYY "oder sogar an Ende" DD.MM.YY
Форматы без разделителя DDMMYYYY не учитывать
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);