#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*(?:<div|<\/div>))(.+?)(?=<br\s?\/>|$)"
Local $sString = "<div class="latestItemIntroText">" & @CRLF & _
"" & @CRLF & _
" <div class="itemLinks">" & @CRLF & _
" <div class="share">Share</div>" & @CRLF & _
" <div class="dummy-div"></div>" & @CRLF & _
"" & @CRLF & _
" <div class="addthis_sharing_toolbox"></div>" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
" Lorem ipsum <br /><br />" & @CRLF & _
" Lorem ipsum <br /><br />" & @CRLF & _
" Lorem ipsum <br /><br />" & @CRLF & _
" Lorem ipsum <br /><br />" & @CRLF & _
"Other Text works too." & @CRLF & _
"<div>" & @CRLF & _
"some inner text" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")