use strict;
my $str = '<div class="latestItemIntroText">
<div class="itemLinks">
<div class="share">Share</div>
<div class="dummy-div"></div>
<div class="addthis_sharing_toolbox"></div>
</div>
Lorem ipsum <br /><br />
Lorem ipsum <br /><br />
Lorem ipsum <br /><br />
Lorem ipsum <br /><br />
Other Text works too.
<div>
some inner text
</div>
</div>
';
my $regex = qr/^(?!.*(?:<div|<\/div>))(.+?)(?=<br\s?\/>|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}