$re = '/^(?!.*(?:<div|<\/div>))(.+?)(?=<br\s?\/>|$)/m';
$str = '<div class="latestItemIntroText">
<div class="itemLinks">
<div class="share">Share</div>
<div class="dummy-div"></div>
<div class="addthis_sharing_toolbox"></div>
</div>
Lorem ipsum <br /><br />
Lorem ipsum <br /><br />
Lorem ipsum <br /><br />
Lorem ipsum <br /><br />
Other Text works too.
<div>
some inner text
</div>
</div>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);