import Foundation
let pattern = #"^(?!.*(?:<div|<\/div>))(.+?)(?=<br\s?\/>|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div class="latestItemIntroText">
<div class="itemLinks">
<div class="share">Share</div>
<div class="dummy-div"></div>
<div class="addthis_sharing_toolbox"></div>
</div>
Lorem ipsum <br /><br />
Lorem ipsum <br /><br />
Lorem ipsum <br /><br />
Lorem ipsum <br /><br />
Other Text works too.
<div>
some inner text
</div>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)