using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<k>\w+)=(?<v>[^;]+);?";
string input = @"path=/; expires=Thu, 05-Nov-2020 12:26:21 GMT; secure; HttpOnly; SameSite=None";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}