package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<k>\w+)=(?<v>[^;]+);?`)
var str = `path=/; expires=Thu, 05-Nov-2020 12:26:21 GMT; secure; HttpOnly; SameSite=None`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}