const regex = /(?<k>\w+)=(?<v>[^;]+);?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<k>\\w+)=(?<v>[^;]+);?', 'gm')
const str = `path=/; expires=Thu, 05-Nov-2020 12:26:21 GMT; secure; HttpOnly; SameSite=None`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}