$re = '/(?<k>\w+)=(?<v>[^;]+);?/m';
$str = 'path=/; expires=Thu, 05-Nov-2020 12:26:21 GMT; secure; HttpOnly; SameSite=None';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);