package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^\([0-9]{5,20}BP01(.*\_V[0-9\.]+)\_(.*)CcID\:(.*)\)`)
var str = `(028042162717BP01GT02D-TK006-HS-SLW-JLX_V2.4_190712CCID:8938003992584686412F)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}