import Foundation
let pattern = #"^\([0-9]{5,20}BP01(.*\_V[0-9\.]+)\_(.*)CcID\:(.*)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"(028042162717BP01GT02D-TK006-HS-SLW-JLX_V2.4_190712CCID:8938003992584686412F)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}