// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^\([0-9]{5,20}BP01(.*\_V[0-9\.]+)\_(.*)CcID\:(.*)\)").unwrap();
let string = "(028042162717BP01GT02D-TK006-HS-SLW-JLX_V2.4_190712CCID:8938003992584686412F)";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}