re = /^\([0-9]{5,20}BP01(.*\_V[0-9\.]+)\_(.*)CcID\:(.*)\)/i
str = '(028042162717BP01GT02D-TK006-HS-SLW-JLX_V2.4_190712CCID:8938003992584686412F)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end