package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|\s)[a-z]`)
var str = `sdagdsagdsag
gsdagdsag
dsgdsagdsgsdg
.. gsdag1021lrnmf.sd
gsdagdsag
dgasdgsdg
g
sdgsdag
sadg s
124145
25
3 3
3
bfdhgdfh hfd
df
hhf
fhffd
hdhfdh fhdhfd h
fdsfhdsfhdfh ffd2
3223
222232G
pl, n..g
dfa
g
ahg
dafopuiqop.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}