import Foundation
let pattern = #"(?:^|\s)[a-z]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
sdagdsagdsag
gsdagdsag
dsgdsagdsgsdg
.. gsdag1021lrnmf.sd
gsdagdsag
dgasdgsdg
g
sdgsdag
sadg s
124145
25
3 3
3
bfdhgdfh hfd
df
hhf
fhffd
hdhfdh fhdhfd h
fdsfhdsfhdfh ffd2
3223
222232G
pl, n..g
dfa
g
ahg
dafopuiqop.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)