const regex = /(?:^|\s)[a-z]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\s)[a-z]', 'gm')
const str = `sdagdsagdsag
gsdagdsag
dsgdsagdsgsdg
.. gsdag1021lrnmf.sd
gsdagdsag
dgasdgsdg
g
sdgsdag
sadg s
124145
25
3 3
3
bfdhgdfh hfd
df
hhf
fhffd
hdhfdh fhdhfd h
fdsfhdsfhdfh ffd2
3223
222232G
pl, n..g
dfa
g
ahg
dafopuiqop.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}