re = /(?:^|\s)[a-z]/m
str = 'sdagdsagdsag
gsdagdsag
dsgdsagdsgsdg
.. gsdag1021lrnmf.sd
gsdagdsag
dgasdgsdg
g
sdgsdag
sadg s
124145
25
3 3
3
bfdhgdfh hfd
df
hhf
fhffd
hdhfdh fhdhfd h
fdsfhdsfhdfh ffd2
3223
222232G
pl, n..g
dfa
g
ahg
dafopuiqop.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end