using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Concepto\s+(?>de la )?(?>tr.+erencia|traspaso)\s+(?P<concepto>.+?)\s*$";
string input = @"Concepto de la transferencia Un concepto uno
Concepto traspaso Orden #121231
Concepto trasnferencia 121231 Magical Concept ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}