$re = '/Concepto\s+(?>de la )?(?>tr.+erencia|traspaso)\s+(?P<concepto>.+?)\s*$/m';
$str = 'Concepto de la transferencia Un concepto uno
Concepto traspaso Orden #121231
Concepto trasnferencia 121231 Magical Concept ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);