import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Concepto\\s+(?>de la )?(?>tr.+erencia|traspaso)\\s+(?P<concepto>.+?)\\s*$";
final String string = "Concepto de la transferencia Un concepto uno \n"
+ "Concepto traspaso Orden #121231\n"
+ "Concepto trasnferencia 121231 Magical Concept ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}