re = /Concepto\s+(?>de la )?(?>tr.+erencia|traspaso)\s+(?P<concepto>.+?)\s*$/m
str = 'Concepto de la transferencia Un concepto uno
Concepto traspaso Orden #121231
Concepto trasnferencia 121231 Magical Concept '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end