using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\p{L}].*){128}";
string input = @"hello heywcewcewcewccdfewfwrfrwfrwfwerfwrfrwgfwrewfvr3gefvrfsg gvwgrfwrfwrfrwfrwfrwfrwfrwegrewgerwgregrgrwgrwgrw efwefewfewfewfwefewfewfwef wefwefwef efefefefefefefef";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}