$re = '/([\p{L}].*){128}/u';
$str = 'hello heywcewcewcewccdfewfwrfrwfrwfwerfwrfrwgfwrewfvr3gefvrfsg gvwgrfwrfwrfrwfrwfrwfrwfrwegrewgerwgregrgrwgrwgrw efwefewfewfewfwefewfewfwef wefwefwef efefefefefefefef';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);