re = /([\p{L}].*){128}/
str = 'hello heywcewcewcewccdfewfwrfrwfrwfwerfwrfrwgfwrewfvr3gefvrfsg gvwgrfwrfwrfrwfrwfrwfrwfrwegrewgerwgregrgrwgrwgrw efwefewfewfewfwefewfewfwef wefwefwef efefefefefefefef'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end