# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a href="(.*?)"/$1/g;t' <<< "<a href=\"/i/info/14259.html\" class=\"ogrLink\">Department page</a>"