import Foundation
let pattern = #"<a href="(.*?)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<a href="/i/info/14259.html" class="ogrLink">Department page</a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)