$re = '/<a href="(.*?)"/';
$str = '<a href="/i/info/14259.html" class="ogrLink">Department page</a>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;