// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a href="(.*?)""#).unwrap();
let string = "<a href=\"/i/info/14259.html\" class=\"ogrLink\">Department page</a>";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}