const regex = /[\r\n]?BEGIN((?!TRUE).)*?END/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\r\\n]?BEGIN((?!TRUE).)*?END', 'gs')
const str = `BEGIN
DESCRIPTION: 1234
BOOL:TRUE
END
BEGIN
DESCRIPTION: 4568
BOOL:TRUE
END
BEGIN
DESCRIPTION: 715310
BOOL:FALSE
END
BEGIN
DESCRIPTION: 12489453
BOOL:TRUE
END
BEGIN
DESCRIPTION: 41543
BOOL:FALSE
END`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);