import re
regex = re.compile(r"[\r\n]?BEGIN((?!TRUE).)*?END", flags=re.DOTALL)
test_str = ("BEGIN\n"
"DESCRIPTION: 1234\n"
"BOOL:TRUE\n"
"END\n"
"BEGIN\n"
"DESCRIPTION: 4568\n"
"BOOL:TRUE\n"
"END\n"
"BEGIN\n"
"DESCRIPTION: 715310\n"
"BOOL:FALSE\n"
"END\n"
"BEGIN\n"
"DESCRIPTION: 12489453\n"
"BOOL:TRUE\n"
"END\n"
"BEGIN\n"
"DESCRIPTION: 41543\n"
"BOOL:FALSE\n"
"END")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)