re = /[\r\n]?BEGIN((?!TRUE).)*?END/
str = 'BEGIN
DESCRIPTION: 1234
BOOL:TRUE
END
BEGIN
DESCRIPTION: 4568
BOOL:TRUE
END
BEGIN
DESCRIPTION: 715310
BOOL:FALSE
END
BEGIN
DESCRIPTION: 12489453
BOOL:TRUE
END
BEGIN
DESCRIPTION: 41543
BOOL:FALSE
END'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result